What versions of Dynamics CRM are compatible with other Microsoft software as of today?

If you were to setup these versions of Microsoft Dynamics CRM today, these are the other pieces of software that you would need to use with it in order to be supported by Microsoft.

As with all compatibilities, these are valid for the day of publishing but could change at any point after.

Office VersionCRM 2016CRM 2015CRM 2013CRM 2011
O365CompatibleCompatibleNot CompatibleNot Compatible
2016CompatibleCompatibleCompatibleCompatible
2013CompatibleCompatibleCompatibleCompatible
2010CompatibleCompatibleCompatibleCompatible
2007
SP2 or 3
Not CompatibleNot CompatibleCompatibleCompatible
2007Not CompatibleNot CompatibleCompatibleNot Compatible

 

CRM Outlook ClientCRM 2016CRM 2015CRM 2013CRM 2011
2016CompatibleNot CompatibleNot CompatibleNot Compatible
2015CompatibleCompatibleNot CompatibleNot Compatible
2013Not CompatibleCompatibleCompatibleNot Compatible
2011Not CompatibleNot CompatibleCompatibleCompatible

 

BrowserCRM 2016CRM 2015CRM 2013CRM 2011
Edge 8
(Win 10)
CompatibleCompatibleCompatibleNot Compatible
Edge 7Not CompatibleCompatibleCompatibleNot Compatible
Edge 6Not CompatibleNot CompatibleCompatibleNot Compatible
IE 12CompatibleCompatibleCompatibleNot Compatible
IE 11 (UR 17)CompatibleCompatibleCompatibleNot Compatible
IE 11CompatibleCompatibleCompatibleCompatible

Note: Windows 7, Windows 8, Windows 8.1, and Windows 10 are the currently supported versions of Windows for CRM compatibility.

For additional compatibility information, please go to these Microsoft support pages.

CRM 2016

CRM 2015

CRM 2013

CRM 2011


Leave a Reply

Your email address will not be published.

X